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Creating Desktop Recordings with Camtasia Studio 2
By: Paul Newman
If you've spent some time on CommunityMX.com, you probably already know that we offer video
tutorials (http://www.communitymx.com/search.cfm?searchbox=camtasia) . Recently, the kind folks at
TechSmith (http://www.techsmith.com/) sent us a few copies of the latest version of their desktop recording
software, Camtasia Studio 2 (http://www.techsmith.com/products/studio/) . As someone who used Camtasia
Studio 1.1, I can tell you that Camtasia Studio 2 is much easier and more intuitive to use than its
predecessor. In addition, it's nearly half the price of Macromedia's desktop recording solution, RoboDemo
(http://www.macromedia.com/go/robodemo/) .
NOTE: At the time of this writing, Camtasia Studio 2 requires Windows 2000 or Windows XP,
and is not available for the Mac platform. If you want to create desktop recordings on
Windows 98, ME or NT, you'll need to use Camtasia Studio 1.1
(http://www.techsmith.com/download/studio98meNTsupport.asp) .

In this tutorial, you'll learn how to record screen actions with Camtasia Studio 2, assemble the elements of
your project, and publish the completed video to Flash SWF format.

Camtasia Workflow
The basic workflow in Camtasia is this:
1. Record your screen actions with Camtasia Recorder
(http://www.communitymx.com/content/article.cfm?page=2&cid=26782#record)

2. Edit your project in Camtasia Studio
(http://www.communitymx.com/content/article.cfm?page=3&cid=26782#project)

3. Produce the video in Flash SWF format
(http://www.communitymx.com/content/article.cfm?page=3&cid=26782#produce)

The best way to get started is to watch TechSmith's Using Camtasia Studio 2
(http://www.techsmith.com/videos/studio/Tutorials/using_camtasia_studio_2.html) videos. You can also
download the Getting Started Guide (http://www.techsmith.com/products/studio/documentation.asp) in PDF
format (direct download (http://www.techsmith.com/transfer.asp?filename=studio.pdf) ). The trial version
(http://www.techsmith.com/download/studiofreetrial.asp) is fully functional for 30 days.

Setting Up Your Microphone
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To record narration, I recommend using a combination headset/boom microphone
(http://www.labtec.com/index.cfm?page=gear/listing&crid=8&crid2=9&countryid=1001&languageid=1) . Make

sure that Mute is unchecked under Microphone in Volume Control (see Figure 1). Also, turn down the
volume on your desktop speakers to avoid feedback. (To open Volume Control, double-click the Volume
icon in the system tray.)

Figure 1 Make sure to uncheck Mute under Microphone
At this point, you should be able to hear yourself speaking in the headset.

The Three R's: Write, Rehearse, Record
When I first started using Camtasia Studio, I recorded screen actions without audio and added the
narration later. I've since learned that it's easier, and faster, to record video and audio at the same time.
Write — For long presentations, TechSmith recommends writing a script that you can
read back as you record your video. However, in most cases, the best approach is to
divide your presentation into several shorter videos. Jot down some notes so you'll
remember the key actions you want your recording to include, and keep them nearby so
you can refer to them as you make the recording (or tape them to your monitor).
Rehearse — Before recording, it's a good idea to rehearse the screen actions you want to
capture. For instance, you may use Ctrl+N to open new documents in Dreamweaver, but
the viewer will find the video easier to follow if you select File > New. TechSmith
recommends pausing briefly before you click menus and buttons so the viewer doesn't
miss important steps. This is also a good time to make sure that all the actions you want
to capture fit within the screen dimensions you've defined (e.g., 800x600).
Record — Think of your recordings as movie takes. If you're well prepared, you should be
able to complete your video in 3-5 takes. The key is making the recordings back-to-back,
without breaks, so you can remember what you did in previous takes and make any
necessary corrections. If you flub a line, don't stop. Instead, collect your thoughts, don't
move your cursor, and resume the recording by repeating the flubbed line. (Alternatively,
you can press F11 to pause/resume the recording, but I just let it keep rolling.) Later,
you can easily select the mistake in the project Timeline, and click Cut Selection to
remove it.

Use a friendly, conversational tone, and don't be discouraged if your video isn't perfect. If you make a
mistake, acknowledge it and move on (i.e., don't be a robot).
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Recording Screen Actions with Camtasia Recorder
Complete the following steps to launch and configure Camtasia Recorder:
1. Choose Start > Programs > Camtasia Studio 2 > Camtasia Studio. This opens the
Welcome dialog box:

2. Select Start a new project by recording the screen and click OK. This launches the
New Recording Wizard.
3. Select Region of the screen and Record Audio. Click Next.
NOTE: Once you're familiar with Camtasia Studio, you can click Cancel when the New
Recording Wizard appears to go straight to Camtasia Recorder.
4. On the following screen, accept the defaults and click Next (we're going to define the
capture region later).
5. Speak into your microphone and adjust the input level accordingly. Click Next.
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6. On the next screen, check Disable display acceleration during capture to create a
smoother recording (this makes the screen go blank temporarily before and after each
recording). Under Post-Recording Options, accept the default (After save, play the
video).
7. Click Finish. This launches Camtasia Recorder. (To return to the New Recording Wizard,
choose Capture > Wizard in Camtasia Recorder.)
8. Before we start recording, let's tweak some additional settings. Select the View menu
and check the Audio and Cursor toolbars.
9. Make sure Record Audio and Show Cursor are selected.
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10. To define the capture region, select Capture > Input > Fixed Region. Enter the
recording dimensions in the Width and Height text boxes and uncheck Fixed starting
point.

This enables you to select the starting point before the recording begins (for some reason,
this option is left out of the New Recording Wizard). Click OK to close the Fixed Region
dialog box.
NOTE: When I first started using Camtasia Studio, I enabled AutoPan and recorded the screen
at 400x300. However, this results in much larger file sizes because Camtasia has to keep
redrawing the entire screen. If you're working with applications such as Dreamweaver and
Flash, I recommend recording the screen at 800x600 and opening the completed video in a
pop-up window. You can use a utility such as Screen Ruler (http://www.microfox.com/) to adjust
the size of the application before recording.
11. Choose Tools > Options and select the Capture tab. To capture tooltips in an
application, check Capture layered windows and click OK.
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12. At this point, you're ready to start recording. Click the red Record button on Camtasia
Recorder, or press F11.
TIP: For a clean recording, minimize all windows except the application you want to capture,
and select a solid background color for your desktop. I chose the Default (blue) Windows XP
color scheme (RGB: 0, 78, 152). If you're using Windows XP, you can hide your desktop
icons by right-clicking the desktop and unchecking Arrange Icons By > Show Desktop
Icons
13. If you unchecked Fixed starting point in Step 10, position the frame to define the
capture region and click the screen to start recording. (Press Esc to cancel.) When the
frame starts to flash, the recording has begun. You can reposition the capture region by
dragging one of the flashing green corners. To pause the recording, press F11.
14. When you're finished, press F10 to stop the recording. Camtasia Recorder prompts you
for a filename and location to save the AVI file.

At this point, the recording plays back in Camtasia Player. This AVI file will be the basis for your project.

Editing Your Project in Camtasia Studio
To create a new project, launch Camtasia Studio (if it's not already open) and complete the following
steps:
1. Click Import video in the Task List and select the AVI file you just recorded.
2. Click the Save Project button on the toolbar (or press Ctrl+S).
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3. Enter a name for the project in the Save As dialog box and click Save. Camtasia Studio
automatically appends the .camproj file extension.
4. Drag the video from the Clip Bin and drop it onto the Timeline. A video preview appears
on the right. You can use the playback controls (Play, Stop, etc.) to view the video you
just created. For more precise control, use the seek bar in the Timeline or the "scrubber"
bar in the video preview area (see Figure 6).

Figure 6 Use the seek bar in the Timeline or the "scrubber" bar in the preview area
5. Make any necessary edits by selecting a portion of the video track and clicking Cut
Selection (the scissors icon in Figure 6). Camtasia Studio uses non-destructive editing,
which means that any changes you make to the video do not affect the original AVI file.
When you reopen the project, the edits you made are preserved and will be rendered
when you produce the final video.
6. To create a title card for the video, create an image with your recording's dimensions in
Fireworks or another image editor. Save the image — Camtasia recognizes BMP, GIF, JPG,
and PNG files — to the directory that contains your other Camtasia project files.
7. Back in Camtasia Studio, click Import images in the Task List and select the image you
just created.
8. Drag the image from the Clip Bin and drop it onto your AVI file in the Timeline. This
inserts the image before your video. By default, the image's duration is 5 seconds. To
change the title card's duration — three seconds ought to be enough — position your
cursor between the image and AVI files until it changes to a double-sided arrow, then
drag to change the clip's duration. As you drag, the time updates in the bottom right of
the video preview area.
9. Save your work.
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To reopen your project, you can double-click the .camproj file in Windows Explorer, or choose File >
Recent Projects > yourProject.camproj in Camtasia Studio.

Producing the Video in SWF Format
The last step is launching the Production Wizard so you can publish your video as an optimized Flash
SWF file:
1. Click Produce video as in the Task List (see Figure 6), or choose File > Produce Video
As. This opens the Production Wizard dialog box.
2. Select Macromedia Flash (SWF) movie file and click Next.

3. On the Flash Encoding screen, change Colors to 16-Bit (High Color) and Frame Rate to
5. If you want your presentation to start playing back immediately, make sure Pause At
Start is unchecked.
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NOTE: I reduced a 5-minute video from 9MB to 4MB by changing 32-bit color to 16-bit color,
and from 4MB to 3MB by changing Frame Rate from 15 to 5 frames per second. For the MP3
audio, I selected 16kBits/sec, the lowest tolerable setting. If your project includes music or
effects, you may need to increase the audio quality. Obviously, these optimizations are only
necessary for streaming web delivery. If you're creating a CD-ROM, go crazy.
4. Click Options next to Playback Controls. This opens the following dialog box:
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Figure 9 Playback Control Options dialog box
5. If you want to include an author credit or copyright statement, check Show about box
and enter up to 8 lines of text.
6. By default, Camtasia Studio uses the loading movie shown below:

If you prefer to use your own loading movie, simply create a looping SWF file in Flash that
matches your video's dimensions. Click the folder icon (see Figure 9) to browse to your
pre-loader SWF file.
7. Click OK to close the Playback Control Options dialog box.
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8. Click Next.
9. On the Video Size screen, make sure Largest video size is selected. Click Next.

10. Unless you want to embed a watermark, click Next.
11. On the final screen, select a folder and enter a filename for your completed SWF file. (You
might want to create a subfolder of your working directory called complete to keep these
files separate from your project source files.) Accept the default Post Production Options,
as shown below.

12 of 20

12. Click Finish. Camtasia Studio converts the project to Flash SWF format (this may take
several minutes), and generates additional files to display it within an HTML page.

13. When the movie is completed, the Production Results dialog box appears, listing
information such as files created, content duration, file sizes, and so forth. Click Close.

Camtasia Studio launches the completed project in your default browser.
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Figure 12 The completed Camtasia video in Internet Explorer 6
Notice that Camtasia Studio generates five different files to display your presentation:
myVideo.html
myVideo.swf
myVideo_config.xml
myVideo_controller.swf
myVideo_preload.swf
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If you open myVideo.html in a text editor, you'll see the following code:
<html>
<head>
<title>Macromedia Flash (SWF) Movie Created by Camtasia
Studio 2</title>
</head>
<body bgcolor="#FFFFFF">
<object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000"
codebase="http://download.macromedia.com/pub/shockwave/cabs/
flash/swflash.cab#version=5,0,0,0" width="400" height="317"
id="myMovieName">
<param name="movie"
value="myVideo_controller.swf?csConfigFile=myVideo_config.xml">
<param name="quality" value="high">
<param name="bgcolor" value="#FFFFFF">
<param name="FlashVars"
value="csConfigFile=myVideo_config.xml">
<embed
src="myVideo_controller.swf?csConfigFile=myVideo_config.xml"
FlashVars="csConfigFile=myVideo_config.xml" quality=high
bgcolor=#FFFFFF width=400 height=317
type="application/x-shockwave-flash"
pluginspace="http://www.macromedia.com/go/getflashplayer">
</embed>
</object>
</body>
</html>

Notice that the Flash movie embedded in the HTML page is myVideo_controller.swf. This file contains
all the ActionScript logic for pre-loading your video (myVideo.swf), displaying the loading video
(myVideo_preload.swf), and generating the playback controls (Play, Pause, Stop, About, etc.). In
addition, if you open myVideo_config.xml in a text editor, you'll see that it contains most of the settings
you selected in the Production Wizard:
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<config>
<AutoStart>1</AutoStart>
<MovieWidth>400</MovieWidth>
<MovieHeight>300</MovieHeight>
<BackgroundColor>FFFFFF</BackgroundColor>
<MovieURL>myVideo.swf</MovieURL>
<ShowLoadingMov>1</ShowLoadingMov>
<LoadingMovURL>myVideo_preload.swf</LoadingMovURL>
<ScaleLoadingMov>0</ScaleLoadingMov>
<LoadingMovPercentToLoad>30</LoadingMovPercentToLoad>
<LoadingMovMinDuration>3</LoadingMovMinDuration>
<ControllerColor>C0C0C0</ControllerColor>
<ShowFFRW>1</ShowFFRW>
<ShowAbout>1</ShowAbout>
<AboutBoxText>©2004 CommunityMX.com
All right reserved.</AboutBoxText>
<TimeDisplayFormat>MM:SS</TimeDisplayFormat>
<ShowDuration>1</ShowDuration>
<ShowElapsedTime>1</ShowElapsedTime>
<TimeDisplayFont>Arial</TimeDisplayFont>
<TimeDisplayFontColor>000000</TimeDisplayFontColor>
</config>

In other words, you can change many of your video preferences by editing this XML configuration file,
rather than republishing your project using Camtasia Studio. The controller movie
(myVideo_controller.swf) loads these XML values at run-time, and uses them to customize settings such
as whether the video starts automatically (AutoStart ), what percentage of the video to pre-load
(LoadingMovPercentToLoad ), and the contents of the About box
(AboutBoxText ). Try editing these values and refreshing myVideo.html in a browser to see the
effects of your changes.

Adding Your Camtasia Video to a Web Page
To add a Camtasia video to a web page, you have two options: open the video in a pop-up window
(recommended), or embed the video in the page.

Opening the Video in a Pop-Up Window

The easiest way to add your video is to open it in a pop-up window using Dreamweaver's
MM_openBrWindow function. In fact, if your video exceeds 500 pixels in width, this may be your
only option. (View the following CMX article for an example that uses pop-ups: "Creating a 3-D Pie
Chart in Fireworks MX 2004 (http://www.communitymx.com/abstract.cfm?cid=AA70198F27A1641B) .")
Complete the following steps to open your Camtasia video in a pop-up window:
1. Click Download Support Files at the bottom of this page. Extract the zip file and install
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the CMX Camtasia Pop-up Window extension (Camtasia_popup.mxp). This is a code
snippet for Dreamweaver MX and Dreamweaver MX 2004.
2. Launch Dreamweaver and create a new HTML document (e.g., part1.htm). Save it in the
same folder that contains your Camtasia assets. (If you haven't copied your Camtasia
files into your Dreamweaver site, do that now.)
3. Switch to Code view and delete all of the page's code.
4. Open the Snippets panel (Window > Snippets) and expand the Community MX folder.
5. Double-click Camtasia Pop-up Window in the Snippets panel to insert the following
code:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01
Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">
<html>
<head>
<title>Video Title</title>
<meta http-equiv="Content-Type" content="text/html;
charset=iso-8859-1">
<style type="text/css">
<!-body {
margin: 0px;
}
a {
font-family: Verdana, Arial, Helvetica, sans-serif;
font-size: 12px;
}
a:link {
color: #000066;
text-decoration: none;
}
a:visited {
color: #000066;
}
a:hover {
color: #000066;
text-decoration: underline;
}
-->
</style>
</head>
<body>
<div align="center">
<p>
<!-- Insert OBJECT block here using the CMX Insert Camtasia
Video extension from CommunityMX.com -->
</p>
<p><a href="javascript:;" onClick="self.close()">Close
browser window</a></p>
</div>
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</body>
</html>

6. At this point, all you have to do is copy the <o bje ct> block from the HTML file
generated by Camtasia Studio and paste it into the pop-up template. For example:

<object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000"
codebase="http://download.macromedia.com/pub/shockwave/cabs/
flash/swflash.cab#version=5,0,0,0" width="800"
height="617" id="myMovieName">
<param name="movie"
value="myVideo_controller.swf?csConfigFile=myVideo_config.xml">
<param name="quality" value="high">
<param name="bgcolor" value="#FFFFFF">
<param name="FlashVars"
value="csConfigFile=myVideo_config.xml">
<embed
src="myVideo_controller.swf?csConfigFile=myVideo_config.xml"
FlashVars="myVideo_config.xml" quality=high bgcolor=#FFFFFF
width=800 height=617 type="application/x-shockwave-flash"
pluginspace="http://www.macromedia.com/go/getflashplayer">
</embed>
</object>

NOTE: You can also insert the Camtasia code block above using the CMX Insert Camtasia
Video extension (http://www.communitymx.com/abstract.cfm?cid=C7B53) .
7. To launch this pop-up window from another document, open an existing web page or
create a new document in Dreamweaver.
8. Create a null link by selecting some text in the Document window and entering
ja vas cri pt: ; in the Link text box of the Property inspector.
9. Make sure the null link (<a > ) is selected and open the Behaviors panel (Window >
Behaviors).
10. Click the Plus (+) button and select Open Browser Window:

11. Click Browse to select the pop-up window you created earlier.
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12. Make sure the pop-up is 70 pixels taller than your video dimensions to accommodate the
controller and the Close browser window link. For example, if your video is 800x600,
open a 800x670 browser pop-up.
13. Click OK to apply the Open Browser Window behavior.
14. Save your work.

On Community MX, our pop-up links include the title of the video, followed by a brief description, as
shown below:
Part 1: Using Camtasia Recorder (javascript:;)
In Part 1 of this tutorial, you'll learn how to tweak the settings of Camtasia Recorder.
Opens new window. Approximate download size: 271K
Part 2: Using ScreenPad (javascript:;)
In Part 2 of this tutorial, you'll learn how to add callouts to your videos using ScreenPad.
Opens new window. Approximate download size: 278K

Embedding the Video in an HTML Page

If your Camtasia video is small enough to embed in a page, you have two options: download the CMX
Insert Camtasia Video extension (http://www.communitymx.com/abstract.cfm?cid=C7B53) , or follow the
instructions below.
1. In Dreamweaver, open the document into which you want to insert the Camtasia video.
2. Open the HTML file generated by Camtasia Studio in Dreamweaver.
3. In Design view, select the Flash object in the second Document window and press Ctrl+C
to copy it.
4. Switch to the first document and place your cursor where you want the Camtasia video to
appear.
5. Press Ctrl+P to paste the Flash object into the document.

Alternatively, you can copy and paste the <object> block using a text editor, as described in the
pop-up section earlier. You may have to edit the paths if your Camtasia assets are not located in the same
folder as your HTML document. For example, if you placed your Camtasia files — myVideo.swf,
myVideo_controller.swf, myVideo_preload.swf, myVideo_config.xml — in a folder called assets, the
code block would look like this (the new code is highlighted):
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<object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000"
codebase="http://download.macromedia.com/pub/shockwave/cabs/
flash/swflash.cab#version=5,0,0,0" width="400"
height="317">
<param name="movie"
value="assets/myVideo_controller.swf?csConfigFile=assets/
myVideo_config.xml">
<param name="quality" value="high">
<param name="bgcolor" value="#ffffff">
<param name="FlashVars" value="csConfigFile=assets/
myVideo_config.xml">
<embed
src="assets/myVideo_controller.swf?csConfigFile=assets/
myVideo_config.xml"
flashvars="csConfigFile=assets/myVideo_config.xml"
quality=high bgcolor=#ffffff
pluginspace="http://www.macromedia.com/go/getflashplayer"
type="application/x-shockwave-flash" width="400"
height="317"></embed>
</object>

Here is an example of an embedded Camtasia video:

Unlike pop-ups, you don't want embedded videos to start automatically. This setting is controlled by the
<AutoStart> tag in myVideo_config.xml: <AutoStart>0</AutoStart> . A value
of 1 means true, 0 means false. View the following article for another example of embedded videos:
"Instant Replay Part 1 - Fireworks (http://www.communitymx.com/abstract.cfm?cid=807A1) ."

Conclusion
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I hope this tutorial inspires you to experiment with Camtasia Studio 2. There's a lot more you can do with
Camtasia than we covered here. For example, if you own Flash MX Professional 2004, Camtasia Studio
can produce your project in Flash video (.flv) format. In addition, you can add callouts, hotspots, and
transitions to your desktop recording.
If you use Camtasia Studio frequently, take a look at the CMX Insert Camtasia Video extension
(http://www.communitymx.com/abstract.cfm?cid=C7B53) . This extension adds a Camtasia Video button to
Dreamweaver's Insert bar to simplify embedding Camtasia videos into HTML documents.
Approximate download size: 1.1MB
To view these videos offline, click Download Support Files at the bottom of this page.
Extract the zip file to a folder on your computer and double-click video\index.htm to launch
the tutorial in your default browser. Approximate download size: 1.1MB
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